Description

The instance's operating system, which must be set to one of the following.

A supported Linux operating system: An Amazon Linux version, such as Amazon

Linux 2016.03, Amazon Linux 2015.09, or Amazon Linux 2015.03.

A supported Ubuntu operating system, such as Ubuntu 16.04 LTS, Ubuntu

14.04 LTS, or Ubuntu 12.04 LTS.

 CentOS 7

 Red Hat Enterprise Linux 7

A supported Windows operating system, such as Microsoft Windows Server

2012 R2 Base, Microsoft Windows Server 2012 R2 with SQL Server Express, Microsoft Windows Server 2012 R2 with SQL Server Standard, or Microsoft Windows Server 2012 R2 with SQL Server Web.

A custom AMI: Custom.

For more information on the supported operating systems, see AWS OpsWorks

Operating Systems (http://docs.aws.amazon.com/opsworks/latest/userguide/workinginstances-os.html).

The default option is the current Amazon Linux version. If you set this parameter to Custom, you must use the AmiId parameter to specify the custom AMI that you want to use. For more information on the supported operating systems, see Operating Systems (http://docs.aws.amazon.com/opsworks/latest/userguide/workinginstances-os.html). For more information on how to use custom AMIs with OpsWorks, see Using Custom AMIs (http://docs.aws.amazon.com/opsworks/latest/userguide/workinginstances-custom-ami.html).

You can specify a different Linux operating system for the updated stack,

but you cannot change from Linux to Windows or Windows to Linux.

Os is referenced in 0 repositories